Campaign Configurator - Marketing Campaign - Create, Edit, Upload Internal Error

Incident Report for DarwinCX

Resolved

This incident has been tested and fully resolved. After a period of successful monitoring, we have confirmed stable service performance and are closing this incident.

Thank you for your patience and understanding.
Posted Jul 03, 2026 - 14:12 UTC

Update

Marketing Campaigns have been partially restored, we are actively working to restore full service.

We will share additional information as it becomes available.
Posted Jul 03, 2026 - 10:14 UTC

Identified

We have identified the cause of an issue impacting some users and are actively working to restore full service.

We will continue to provide updates as remediation progresses.
Posted Jul 02, 2026 - 23:03 UTC

Investigating

We are currently investigating a potential issue that may be impacting some users.

The ability to create, edit or upload new campaigns may be affected.

At this time, impact is still being assessed, and our team is working to better understand the scope.

We will share additional information as it becomes available.
Posted Jul 02, 2026 - 21:52 UTC
This incident affected: Darwin Client & Care App.