Transactions held in queue

Incident Report for DarwinCX

Identified

We have identified the cause of an issue impacting some users and are actively working to restore full service.

Once completed we will endure the transactions are no longer in queue.

We will continue to provide updates as remediation progresses.
Posted Aug 21, 2026 - 21:55 UTC

Investigating

We continue to investigate an issue affecting some users.

Impact remains ongoing at this time and our teams are actively working to identify what is causing transactions to be held in queue.

We will share additional information as it becomes available.
Posted Aug 21, 2026 - 21:05 UTC
This incident affects: Darwin Client & Care App.